Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Domandate qui se non riuscite ad installare i filtri o gli script, oppure se avete problemi legati alla creazione e modifica dei filtri. Qui si pongono le domande più tecniche.
Rispondi
Avatar utente
Sybelius
Gimper
Gimper
Messaggi: 71
Iscritto il: mer 7 giu 2006, 21:32
Località: Gaborone - Botswana

Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da Sybelius » dom 8 apr 2018, 21:39

Ciao Tutti,

Mi trovo su una fresca installazione di Funtoo 64 bit KDE e non riesco ad installare il plugin Gmic_Gimp: ho provato nella cartella /usr/eccetera ed anche in /home/.config/GIMP sia in/plug_ins che in /scripts ma Gimp proprio non lo vede.
Ho usato sia la versione "gtk" che la versione "qt", vi e` un problema di incompatibilita` oppure sono io che non riesco ad installarlo?
Grazie per l'attenzione, ciao

Avatar utente
fabri66
Amministratore
Amministratore
Messaggi: 755
Iscritto il: gio 13 nov 2014, 23:12

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da fabri66 » mar 10 apr 2018, 21:26

Ciao Sybellus,

GMIC è sicuramente compatibile con Gimp 2.9.x e lo trovi sia nelle versioni di Pharta che nel formato "appimage" per Linux che puoi scaricare da qui (il link è comunque nella homepage di Partha e punta alla comunity di PIXLS.US).

Gimp 2.9.9 nel formato appimage con GMIC 2.2.2
Immagine

Domanda: dopo aver scaricato GMIC ed averlo copiato nella cartella giusta (es.: /home/fabrizio/.gimp-2.9/plug-ins/) l'hai reso "eseguibile come programma" ? (scusa la domanda ma a volte io do per scontato che un file sia già configurato come eseguibile quando invece non lo è :mrgreen: e quindi magari capita anche ad altri ...).

Altra domanda: il file eseguibile di GMIC l'hai copiato direttamente nella cartella .../plug-ins/ oppure l'hai copiato in una sottocartella di .../plug-ins/ ? Se l'avessi copiato in una sottocartella, prova ad aggiungerla in "MODIFICA - PREFERENZE - CARTELLE - PLUG-IN" ...

Facci sapere.

A presto e buona serata.
Fabrizio

Avatar utente
Sybelius
Gimper
Gimper
Messaggi: 71
Iscritto il: mer 7 giu 2006, 21:32
Località: Gaborone - Botswana

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da Sybelius » mar 10 apr 2018, 23:00

Ciao Fabrizio,

Grazie per l'aiuto ma qualcosa non va: ho rifatto la procedura scaricando nuovamente GMIC_GIMP plugin e GIMP proprio non lo vede.
Il file e` eseguibile e l'ho posizionato nel percorso /home/.config/GIMP/2.9/plugins che e` anche presente nell'elenco che vien fuori andando a guardare su Modifica>Preferenze>Cartelle>Plug-ins da GIMP.

Non ho scaricato GIMP AppImage da pixls.us perche` ho appena installato il pacchetto specifico per Funtoo (anzi, l'ho reinstallato proprio oggi), magari tra qualche giorno prendo coraggio, lo tolgo e provo la versione di pixls.us che se ho capito bene e` una versione standalone che si puo` installare su qualunque distro.
Funtoo (possiamo dire che e` figlia di Gentoo) e` una nuova esperienza per me, pare sia la "Lamborghini" delle distro Linux ma personalmente sto sperimentando delle incongruenze mai viste su Linux Mint (la mia preferita).

Mi faccio risentire qui appena ho buone notizie :) Ciao

P.S.
Mi ero dimenticato di specificare che sono in ambiente grafico KDE5-Plasma, non so se e` importante

Avatar utente
fabri66
Amministratore
Amministratore
Messaggi: 755
Iscritto il: gio 13 nov 2014, 23:12

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da fabri66 » mer 11 apr 2018, 13:53

Sybellus ha scritto:Non ho scaricato GIMP AppImage da pixls.us perche` ho appena installato il pacchetto specifico per Funtoo (anzi, l'ho reinstallato proprio oggi), magari tra qualche giorno prendo coraggio, lo tolgo e provo la versione di pixls.us che se ho capito bene e` una versione standalone che si puo` installare su qualunque distro.
Ciao, per il momento aggiungo velocemente che il formato "appimage" è un pacchetto completo che comprende tutto il necessario per far funzionare il programma (una sorta di portable app di windows) e quindi non è necessario disinstallare la versione di Gimp che hai già su Funtoo (che non conosco ma che per curiosità andrò a cercare) perchè di fatto nulla di nuovo viene installato sul pc.

Io ad esempio sulla mia Mint ho installato in modo stabile Gimp 2.8.x e ho le appimage delle ultime tre versioni di Gimp 2.9.x (appena la trovo proverò anche Gimp 2.10.x).
L'unica cosa è che non puoi utilizzare contemporaneamente la versione installata e la versione "appimage".

Per l'ambiente grafico, non penso proprio sia un problema ...

Ciao
Fabrizio

Avatar utente
Sybelius
Gimper
Gimper
Messaggi: 71
Iscritto il: mer 7 giu 2006, 21:32
Località: Gaborone - Botswana

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da Sybelius » ven 13 apr 2018, 14:21

Ciao Fabrizio :)
Grazie per la dritta, non sapevo che GIMP-Appimage puo` convivere con quello normalmente installato, ho gia` provato a scaricarlo ma il download non parte (ho problemi con la connessione in questi giorni, spero si risolva presto).
Appena ho novita` le riporto qui, ciao

Avatar utente
Sybelius
Gimper
Gimper
Messaggi: 71
Iscritto il: mer 7 giu 2006, 21:32
Località: Gaborone - Botswana

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da Sybelius » lun 30 apr 2018, 1:02

Ciao Carissimo Fabrizio,

Forse lo sai gia`, comunque ti passo la notizia:
GIMP 2.10 rilasciato
https://itsfoss.com/gimp-2-10-release/

Avatar utente
fabri66
Amministratore
Amministratore
Messaggi: 755
Iscritto il: gio 13 nov 2014, 23:12

Re: Gmic_Gimp plugin non e` compatibile con Gimp 2.9?

Messaggio da fabri66 » lun 7 mag 2018, 22:22

Ciao Sybellus,

innanzitutto scusami se non ho risposto subito e grazie mille per l'info !

Di fatto ho iniziato solo oggi a testare il nuovo Gimp 2.10 su Windows 10 (versione portable di Partha) dove GMIC (per restare in tema) funziona perfettamente, mentre sulla mia Mint 18 ho dei problemi con GMIC che il nuovo Gimp proprio non vede, ed essendo io un "GMIC dipendente" immaginerai la crisi :mrgreen: :mrgreen: :mrgreen:

Comunque sono fiducioso che a breve tutto si risolverà ... ma nel frattempo, visto che per l'installazione ho scelto la versione nel formato "flatpack", ho ancora il buon vecchio Gimp 2.8.22 perfettamente funzionante :wink:

A presto e buona serata.

Fabrizio

Rispondi